GCS FAQ

Installation

  • Insert the GCS CD into the CDROM drive
  • Double click your My Computer Icon
  • Double click your CDROM drive
  • Find Setup.exe and double click it.
  • Follow all the instructions given.
  • Restart the computer if you haven't already
  • Open GCS by double clicking the "GCS for windows" icon on your Desktop
  • Register your software
  • Click the "File" menu option
  • Select "Company Info"
  • Click the green plus sign
  • Fill out the information on the Company Detail screen

If you have any trouble registering your software, go to the section on registration errors HERE.

If you have any difficulties, contact us.


Back to Top


To Configure GCS for 13 Financial Periods

WARNING: Following these steps will wipe out all existing financial information!

  • Make sure GCS is not running
  • Click on the Windows Start button
  • Select "Run"
  • Type GCS.INI, then click OK
  • Find the following lines
    • FinPeriodFormat=Monthly
    • FinNumberPeriods=12
  • Change these lines so that they read:
    • FinPeriodFormat=Equal
    • FinNumberPeriods=13
  • Click on File, then click on Save
  • Click on File, then click on Exit
  • Run GCS
  • From the financial toolbar, click on Setup
  • Click on First Time Setup, and follow the instructions

Back to Top


What is QuickLoad and how do I use it?

    In an effort to reduce the time spent setting up GCS, the QuickLoad utility was designed to help you automatically setup equipment items and their required maintenance schedules, chemicals/fertilizers and their associated MSDS information, and vegetation items (note: not all of the QuickLoad disks may be available to you – check with your distributor for more details). The QuickLoad utility allows you to choose only the items in use at your facility and then automatically loads relevant data directly into GCS.

    After installing GCS and rebooting your computer, you can use the QuickLoad feature. Here are the steps:

  • Click on “Tools” located on the GCS menu bar (the menu bar includes four options and is located above the main GCS picture toolbar).
  • Click on “QuickLoad”.
  • Click on “Equipment” specified in the box labeled “Data to Load”.
  • Using the scroll bar on the lower portion of the QuickLoad utility, find and click on “Program Files”, then use the scroll bar to find and click “InCircuit”, then “GCS”, then “QLoad”, then “Equipment”.
  • Next, click on the “Load Data” button located on the top portion of the QuickLoad utility (the “Load Data” button is directly beneath the word “QuickLoad”).
  • Use the scroll bar to move up and down between equipment items. When you have located an equipment item in use at your course, left click once in the “Use” box located to the left of the item “Make”.
  • After clicking in the box for a particular item, you must enter additional details for that item in the lower portion of the screen (Stock Number, Serial Number, Meter Reading). First, click in the box labeled “Stock Number” and enter a unique stock number to identify that item (note: When assigning stock numbers it is important to be consistent with the type and number of digits and/or characters used for each stock number. It is recommended that you use at least 5 digits for stock numbers. Use alphabet letters to intuitively identify items followed by 3 number digits. For example, instead of just typing stock number “1” for a John Deere mower, use “JD001”). Next, enter the actual “Serial Number” and “Meter Reading” for each equipment item you are loading. If you have more than one (1) of the equipment item selected, click the green “+” button on the top of the QuickLoad screen and another line will appear to enter another stock number and corresponding serial number/meter reading.
  • When you have finished entering corresponding stock numbers for the item that is currently check-marked, use the scroll button located to the right of the “Equipment Group” to find the next equipment item used at your facility, then follow step 6 again. Continue this process until all items have been loaded.
  • Next, click on the “Load Data” button on the QuickLoad toolbar and click on “Yes” when GCS asks if you want to QuickLoad the selected data. GCS should then indicate that all items were successfully QuickLoaded. Click on “OK”.
  • Click on the QuickLoad exit door (located next to the question mark “?”).
  • Finally, refer to your manual on using the Equipment module for regular maintenance activities.

Back to Top


Network Installation

Client Server Installation

On The Server

  • On the server, create the following directory: C:\GCS\data
  • The GCS directory should be available to clients. For example, via network neighborhood, they should be able to see \\server\GCS (where "server" is the network name for the server).
  • Clients need to be granted full access to the GCS and the GCS\data directories. Right-click on the GCS directory while in the Windows Explorer, then select "Sharing" to grant "Full Access" to the directory.

On The Clients

  • On the client, install the software normally, as if it is a stand-alone installation
  • On the first client only, copy all data files from the client to the \\server\GCS\data directory on server. The data files on the client are located in the following directory: C:\program files\InCircuit\GCS\data
  • On the client, run the "BDE Configuration Utility" located in your software's program folder
  • Under "Drivers", highlight Paradox
  • For Parameters, the "Net Dir" setting should be set to \\server\GCS (or whatever the correct address is to the GCS directory on the server). The UNC path is the preferred method. If you must use mapped drives, all clients need to be mapped to the same drive letter. i.e. G:\GCS.
  • Click the "Aliases" tab located at the bottom of the screen
  • Under "Aliases", select GCSDATA
  • Change the "Path" setting to "\\server\GCS\data" (or whatever the correct address is to the GCS Data directory on the server)
  • Click the "System" tab located at the bottom of the screen
  • Find "Local Share" in the left hand column
  • If it says "False" to the right, change it to "True"
  • Click on "File", then select "Save"
  • Click on "File", then select "Exit"
  • Since the data files reside on the server, delete the data files from the client's local hard drive to help conserve disk space and avoid confusion. You can delete the following directories (if they exist): C:\program files\InCircuit\GCS\data
  • Run Software Program, and go into Company Info screen. Change the Data Location to "\\server\GCS\data" (the location of the data on the server)

Peer-to-Peer Installation

On The Host

  • On the computer that will be hosting the data, share the GCS folder. The path to the GCS folder is C:\Program Files\InCircuit\GCS.
  • The GCS directory should be available to clients. For example, via network neighborhood, they should be able to see \\computername\GCS (where "computername" is the network name for the host workstation).
  • Clients need to be granted full access to the GCS and the GCS\data directories. Right-click on the GCS directory while in the Windows Explorer, then select "Sharing" to grant "Full Access" to the directory.

On The Peer Clients

  • On the client, install the software normally, as if it is a stand-alone installation
  • On the client, run the "BDE Configuration Utility" located in your software's program folder
  • Under "Drivers", highlight Paradox
  • For Parameters, the "Net Dir" setting should be set to \\computername\GCS (or whatever the correct address is to the GCS directory on the host workstation). The UNC path is the preferred method. If you must use mapped drives, all clients need to be mapped to the same drive letter. i.e. G:\GCS.
  • Click the "Aliases" tab located at the bottom of the screen
  • Under "Aliases", select GCSDATA
  • Change the "Path" setting to "\\computername\GCS\data" (or whatever the correct address is to the GCS Data directory on the host workstation)
  • Click the "System" tab located at the bottom of the screen
  • Find "Local Share" in the left hand column
  • If it says "False" to the right, change it to "True"
  • Click on "File", then select "Save"
  • Click on "File", then select "Exit"
  • Since the data files reside on the the host workstation, you may delete the data files from the client's local hard drive to help conserve disk space and avoid confusion. You can delete the following directories (if they exist): C:\program files\InCircuit\GCS\data
  • Run Software Program, and go into Company Info screen. Change the Data Location to "\\computername\GCS\data" (the location of the data on the host workstation)

Back to Top


Upgrading

NOTE: If you have ANY custom reports contact us prior to upgrading

  • Click the following link:
  • Upgrades and Maintenance
  • Click the link named "GSC 3.10 to GCS 3.11 Upgrade"
  • Follow the wizard’s instructions

When you are finished

  • Open GCS
  • Click the “Help” menu option (the menu, not the button with the question mark on it)
  • Click “About”
  • Verify that you are running the correct version

If you have any difficulties, or need the password, contact us.


Back to Top


Adding a Chemical Applicator

  • Go into the Chemical module.
  • Click the Applicator icon.
  • Right-click the Funnel (Filter Records) icon. It is next to the printer icon. This will reveal all employees.
  • Click on the employee that you want to make an Applicator and type the State and License number.
  • Click the Check Mark (Post Edit) icon.
  • When you exit this screen and return, only the employees with licenses will appear.

Back to Top


Reports in GCS

  • GCS provides a large variety of reports to make data comparison easy. A book giving examples of some of these reports is now available for download.
  • Please note that this is an 8 MB file and may not be feasible to transfer using a dial-up internet connection.
  • Alternatively, contact us to have a paper copy mailed to you.
  • Download the sample reports book by clicking the link below.


  • GCS Sample Reports Book

    The above require the Adobe Acrobat® Reader™ 4.0 or later. If you do not already have it, click here to download

Back to Top


Common Problems

Fixes for common error messages:

Back to Top


Corrupted Files...

This is a single problem with many causes, no need to fear, we can fix it. There are a few steps we need to take. Make a backup, get instructions on how to make a backup HERE

NOTE: If you are sending in your data, name it: "C:\CourseName.zip"

Click HERE for instructions on sending in your data.

A tech support representative will email/call you shortly. If you have any problems, contact us.


Back to Common Problems


File IO Error, Error 519 or Error 515

This is usually caused by a lack of Disk space, try emptying recycle bin and freeing up other areas of your hard drive. Another option would be to filter out a smaller report.
If your problem persists contact us.

Back to Common Problems


Registration Problems

This is an error involving the registration of GCS. Even though the error says "Invalid Registration Number", the error can be any combination of: User Name, Company Name, Company ID, or the Registration Number. Registration information needs to be typed in EXACTLY as it appears on your registration card. This includes capitol letters, dashes, periods etc.
If you lost your registration information or want to change it contact us.


Back to Common Problems


Security Problems

These errors occur usually after a crash or when the data location is pointing to the wrong directory.

Password already in use
If your computer crashed while you were in GCS, You should have a retry button, click this. It will prompt you to get your system administrator. If you are the System Administrator or you have the System Administrator password, you can click ok. Enter the Security Administrator password and hit ok.

Could not verify Security information
This is caused by two main problems. One being that you crashed while in GCS and the security files are corrupted. Another being that your Data Location contains no Security files. Check the BDE config utility (located in your GCS for windows folder in your start menu) Click the aliases tab, highlight the alias named GCSDATA. Make sure the path listed on the right is valid. If it is not, change it to where your data resides and save changes. If the data path is correct, we only have one other choice (this usually means that your security files are corrupted) Go ahead and contact us at this point

Invalid Password
Remember, the passwords are case sensitive. Is your caps lock on?

Back to Common Problems


Too Many Record Locks

This problem occurs when you try to receive multiple items on a single PO. This problem has been fixed in the upgrade. Get the upgrade along with install instructions HERE (you must be on a support plan to install the upgrade)


Back to Common Problems


Key Violations

Every table has something called a key field(s). It is a field or combination of fields values. They are, and must be, unique to each row. For example, in the inventory table, the stock number is the key. Assuming that you will not have any two like stock numbers, it is a distinguishing factor for all the records, that is, a way to identify each line item in the table. If you attempt to insert a new record into a table, with a duplicate key value, you will get a Key Violation. Usually GCS will tell you what field needs to be changed, but if not, contact us.


Back to Common Problems


Network Troubleshooting

If you are using your data on a network, there are a few things you may need to know...

  • You MUST have full read AND write access to both the data folder and it's parent folder. Make sure that you can indeed save a text file to your data folder and your data's parent folder
  • In your BDE config utility:
    • Click Drivers highlight Paradox
    • Make sure your Net Dir is the parent of the data folder
    • Click the Aliases tab
    • Highlight GCSDATA
    • Make sure your data location is correct
  • Check the Network Install Instructions to make sure all of your
  • settings are correct.

Back to Common Problems


Backing Up Your Data

All of the data in GCS is located in one folder. By Default it is "c:\program files\InCircuit\GCS\data"

To create a backup of your data on diskettes:

  • Open GCS
  • Click the "File" menu option at the top left
  • Click the "Backup" option
  • Click the "Options" menu from the top of the backup window
  • If there is not a check next to "multidisk mode", Click it
  • Click the "File" menu option
  • Select "New"
  • Type "A:\Backup.zip" where it asks for the "File Name"
    NOTE: the word BACKUP is the file name, you can name it anything you want
  • Click the "Save" button
  • Click the "OK" Button when it says you "Click OK to backup to drive A"

To create a backup to your hard drive:

  • Open GCS
  • Click the "File" menu option at the top left
  • Click the "Backup" option
  • Click the "Options" menu from the top of the backup window
  • If there is a check next to "multidisk mode", Click it
  • Click the "File" menu option
  • Select "New"
  • Browse to the location that you want to save your backup
  • Type the desired name in the "File Name" box
    NOTE: You can put the date in a format of 1-1-1999.zip if you want
  • Click the "Save" button
  • Click the "OK" Button when it says "Click OK to backup to drive C"

If you have any problems, contact us.


Back to Top


Restoring your data

To restore any backup file, follow the following steps,

For multi diskette backups:

  • Insert the first backup disk
  • Open GCS
  • Select the "File" menu option
  • Select the "Backup" option
  • Select the "File" menu option on the new, smaller window
  • Select "Restore"
  • In the top drop down box, select your "A:" drive
  • Double click the file that appears in the file list
  • Follow the instructions prompted to you

It will ask you to insert the last disk, then to reinsert the first diskette. This is so the program will know how many diskettes to expect, along with the file names. In other words, this is perfectly normal operation.

For single disk backups:

  • Open Protégé
  • Select the "File" menu option
  • Select the "Backup" option
  • Select the "File" menu option on the new, smaller window
  • Select "Restore"
  • In the top drop down box, select your drive where the backup is located
  • Browse to the file, then double click it

If you have any problems, contact us.


Back to Top


Sending in your data

  • Make a backup. Instructions for backing up are located HERE
  • Post the backup to our ftp site:

If you use Netscape 4.0+ OR Internet Explorer 5.0+ use these instructions:

    Click HERE
  • In the new window that pops up, drag and drop the backup file into it. You will need to contact us at 225-612-2120 for login information.

If you use Netscape 4.0+ you can also use these instructions:

  • (Netscape only) Click the “File” menu option
  • Click “Upload”
  • Find your backup and select it to be uploaded
  • You should see something about “Uploading File”
  • If this does not work follow on

If you are using an older version of the abouve mentioned browsers, follow these instructions:

  • Click Start
  • Click Programs
  • Click “MS-DOS Prompt”
  • Type “FTP webserv.turfcentric.com” then press enter
  • Username is <Contact TurfCentric at (225) 612-2120 for username>
  • Password is <Contact TurfCentric at (225) 612-2120 for password> (you will not see anything you type in for the password so type carefully)
  • When you are logged in you will see the prompt ftp>
  • Type “put c:\data.zip” then hit enter. If this is not the name and location of your file type in the full path and filename for example if your file is named “data.zip” and is located on the desktop, type:
    “put c:\windows\desktop\data.zip”
  • It will say “Opening Binary connection for “c:\data.zip”
  • It won’t look like it is doing anything, do not worry
  • When it is finished it will say x number of bytes transferred in x number of seconds
  • Type ”close” then hit enter
  • Type “quit” then hit enter
  • Type “exit” then hit enter


Back to Top


Comments and Suggestions

Please send us mail with a subject of FAQ, telling us what you think about this page and how we might improve it.


Back to Top



Copyright © 2002 TurfCentric, Inc. All rights reserved.
Back to Home Page